Naautsorse.ru

Связь и коммуникации
7 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Интернет радио из роутера своими руками

Интернет радио из роутера своими руками

Сообщение отредактировал emirov84 — 21.12.16, 14:21

Какие модели мобильных роутеров можно использовать для создания wifi интернет радио ?

1) Nexx WT3020H(F) ( флэш память 8 мб, ОЗУ- 64 мб )
2) Xiaomi Mi-router mini
3) Клоны Hame MPR-A1 на чипе RT5350 ( у меня клон с флэш 4 мб, ОЗУ-32 мб )
4) GL-MT300N ( флэш память 16 мб, ОЗУ- 64 мб )

Выбор операционной системы.

Выбор дополнительного оборудования.

1) Внешняя аудиокарта с кнопками для управления.
2) USB наушники с кнопками для управления
3) Портативная аудиоклонка

С помощью шнурка подсоеденить роутер (вход Lan на роутере) к сетевой карте компьютера.

Прежде чем заливать прошивку, поменяем загрузчик на U-boot. Файл загрузчика скачаем отсюда. Затем будем делать по шагам :

1.Записываем на флэшку u-boot-nexx-3020-7620.bin
2. Подключаем ее в роутер
3. Заходим на роутер по телнет на адрес 192.168.8.1 с логином nexxadmin и паролем y1n2inc.com0755
4. Вводим в командной строке

5. На всякий случай сделаем бэкап

for i in 0 1 2 3; do cat /dev/mtdblock$i > mtdblock$i.bin; done

mtd_write -r -e mtd0 write u-boot-nexx-3020-7620.bin mtd0

После этого роутер должен перезагрузиться с новым загрузчиком, но со старой прошивкой. После выполнения этого шага питание от роутера можно отключить.

Чтобы попасть в загрузчик теперь необходимо зажать кнопку сброса и включить роутер. Подержать 3 секунды и загрузчик запустится в режиме http-сервера на 192.168.1.1. Затем в вэб интерфейсе загрузчика идем по пути Firmware Upgrade, ставим птичку на пункте Firmware, нажимаем Browse и ищем на диске нашу прошивку openwrt-15.05-ramips-mt7620-wt3020-8M-squashfs-sysupgrade.bin и потом Upload. Загрузчик считает прошивку и зеленым цветом известит нас что все в порядке и можно прошиваться. Этот процесс займет пару минут и роутер опять перегрузится. Далее можно заходить браузером по адресу 192.168.1.1 в вэб интерфейс OpenWrt для дальнейшей настройки. Логин по умолчанию root. Пароль придумаете сами. Этот пароль будет использоваться для доступа к роутеру по SSH.

В вэб интерфейсе OpenWrt настроить wifi как клиент. Т.к роутер в дальнейшем будет скачивать с инета пакеты для работы.

1. Зайдем через SSH под рутом по адресу 192.168.1.1 и поставить недостающие пакеты

opkg update
opkg install kmod-sound-core kmod-usb-audio kmod-input-core kmod-input-evdev madplay alsa-utils triggerhappy kmod-hid kmod-usb-hid

3. Выложить содержимое приложенного архива radio.zip в корень файловой системы роутера
4. Поставить права доступа на скрипты

chmod 755 /etc/init.d/webradio
chmod 755 /www/cgi-bin/webradio/items.cgi
chmod 755 /www/cgi-bin/webradio/update.cgi
chmod 755 /www/scripts/getstreammeta.sh
chmod 755 /www/scripts/playback.sh
chmod 755 /www/scripts/playstream.sh
chmod 755 /www/scripts/stopstream.sh
chmod 755 /www/scripts/streamcontrol.sh
chmod 755 /www/scripts/webradio.sh

5. Включить triggerhappy и радио в автозагрузку

/etc/init.d/triggerhappy enable
/etc/init.d/webradio enable

6. Перезагрузить роутер и если все сделано правильно, то по адресу

появится простой веб-интерфейс для управления радио и начнется воспроизведение первой станции из списка.

С помощью элементов управления можно менять позицию той или иной станции, удалять станцию, добавлять станцию. При этом ее название автоматически будет добавляться в каталог.
Нажимая кнопки Vol+ и Vol- можно менять громкость станции, а кнопкой Mute переключать станции вперед по кольцу. Название станции будет проговаривать синтезатор голоса.

Загрузчик менял по методу изложенному в этом посте.

Т.к. у меня клон Hame mpr-a1 с флэш 4 мб, то прошить в лоб стандартный пакет Openwrt и потом вручную установить пакеты как в посте выше просто не получится. В флэш памяти моего роутера не хватает места. Поэтому пришлось собрать прошивку с уже внедренными пакетами.

Прошивку можно скачать по этой ссылке.

Прошивка заливается в роутер с помощью китайской утилиты.

Затем по телнет на адрес 192.168.1.1 и ввести команду passwd. Вводим новый пароль. Теперь можно заходить на роутер с помощью WinSCP. На роутере надо поднять wifi. Для этого в каталоге /etc/config меняем содержимое файла network :

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd85:d10f:62c9::/48’

config interface ‘lan’
option ifname ‘eth0.1’
option type ‘bridge’
option proto ‘static’
option gateway ‘192.168.1.1’
option dns ‘77.88.8.7’
option netmask ‘255.255.255.0’
option ip6assign ’60’
option ipaddr ‘192.168.100.100’

config interface ‘wan’
option ifname ‘eth0.2’
option proto ‘dhcp’
option type ‘bridge’
option metric ’50’

config switch
option name ‘rt305x’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘rt305x’
option vlan ‘2’
option ports ‘4 6t’

config switch_vlan
option device ‘rt305x’
option vlan ‘1’
option ports ‘0 6t’

config interface ‘modem_usb’
option proto ‘dhcp’
option ifname ‘usb0’
option metric ‘100’

config interface ‘wwan’
option dns ‘8.8.8.8’
option proto ‘static’
option ipaddr ‘192.168.1.100’
option netmask ‘255.255.255.0’
option gateway ‘192.168.1.1’

config wifi-device ‘radio0’
option type ‘mac80211’
option hwmode ’11g’
option path ‘10180000.wmac’
option htmode ‘HT20’
option disabled ‘0’
option channel ‘auto’
option country ‘RU’

config wifi-iface
option device ‘radio0’
option mode ‘sta’
option network ‘wwan’
option ssid ‘НАЗВАНИЕ ВАШЕЙ WI-FI СЕТИ ‘
option key ‘ПАРОЛЬ ВАШЕЙ WI-FI СЕТИ ‘
option encryption ‘psk2+aes’

Командой wifi up включаем wifi на роутере. Немного подождем, если синий светодиод на роутере начнет мигать, то все OK.

Роутер можно перезагрузить и доступ к роутеру теперь будет по wifi по адресу 192.168.1.100. По lan можно зайти по адресу 192.168.100.100.

Hame MPR-A1 и клоны на чипе RT5350 (4 мб флэш)

Tplink tl-wr710v2.0 (4мб флэш)

Мануал от samur005 ( для прошивки «Хитрый Домовенок» )

Сообщение отредактировал ctich — 19.02.17, 22:12

Приветствую. К сожалению, я не сильный электронщик. Нарыл только в гугле это и это. И еще можно посмотреть на специализированных форумах.

Да не, тут вопрос не в программировании и не в даташите. Есть подозрение, что под openwrt уже и i2s драйвер есть. Например, в 15.05 есть пакет kmod-sound-mt7620, что вполне может оказаться одним из требуемых пакетов. а вот как оно шаг за шагом подключается и были ли успешные реализации подключения — не понятно. И сведения обрывочные только попадаются, что не могу полную картину воссоздать.
Для платформы ar9331 (tp-link mr3020) китайцы драйверы написали, когда создавали свой airmusic. А тут, вроде, и поддержка i2s изначально есть в процессоре, а полного мануала (по программной части) подключения dac по i2s шине нигде нет. Было бы здорово обойтись без ненужного преобразования через usb. И порт остался бы свободен.

Читать еще:  Доступ к роутеру через интернет

Ладно, в общем, понял, не встречали. Будем искать.

Чем плохо такое преобразование ? Вносятся шумы, искажения при воспроизведении аудио ?

Шумы вряд, это ж цифра. USB конвертер сужает возможности ЦАП по битности и частоте дискретизации. Кроме, того, очень существенно добавляет стоимости к конечному продукту (звуковой карте). Предложений ЦАП без конвертера USB масса — от Китая до «аудиофильских» платок к малинке. После покупки именитой Creative SB Play, как раз для целей подключения к роутеру, в звукашках «от брендов» я совсем разочаровался, ибо ЦАП там древний, как экскременты мамонта. Звук соответствующий.

Если из схемы выбросить USB звук и пересадить его на шину i2s, будет порт usb свободен (флешка для музыки) и можно не использовать USB хаб (он надежности не добавляет, из-за него возможны зависания). В общем, одни плюсы)

На wt3020 процессор mt7620n, на нем, похоже, линии i2s отключены. Доступны они на mt7620a, в xiaomi, но этот роутер пока новый, его никто особо не ковырял.

Спасибо, все работает,
На клоне HAME
Как бы еще добавить регулировку громкости и стоп произведения из веб морды? Звуковая к сожалению без кнопок.

Сообщение отредактировал D_MitriY — 17.03.16, 15:27

Если нужна громкость и кнопка выключения в вэб интерфейсе могу рекомендовать этот проект. Прошивка для RT5350 здесь.
Можно попробовать и скрестить.

Сообщение отредактировал sergej_a_g — 17.03.16, 19:59

Интернет радио из роутера своими руками

Сообщение отредактировал emirov84 — 21.12.16, 14:21

Какие модели мобильных роутеров можно использовать для создания wifi интернет радио ?

1) Nexx WT3020H(F) ( флэш память 8 мб, ОЗУ- 64 мб )
2) Xiaomi Mi-router mini
3) Клоны Hame MPR-A1 на чипе RT5350 ( у меня клон с флэш 4 мб, ОЗУ-32 мб )
4) GL-MT300N ( флэш память 16 мб, ОЗУ- 64 мб )

Выбор операционной системы.

Выбор дополнительного оборудования.

1) Внешняя аудиокарта с кнопками для управления.
2) USB наушники с кнопками для управления
3) Портативная аудиоклонка

С помощью шнурка подсоеденить роутер (вход Lan на роутере) к сетевой карте компьютера.

Прежде чем заливать прошивку, поменяем загрузчик на U-boot. Файл загрузчика скачаем отсюда. Затем будем делать по шагам :

1.Записываем на флэшку u-boot-nexx-3020-7620.bin
2. Подключаем ее в роутер
3. Заходим на роутер по телнет на адрес 192.168.8.1 с логином nexxadmin и паролем y1n2inc.com0755
4. Вводим в командной строке

5. На всякий случай сделаем бэкап

for i in 0 1 2 3; do cat /dev/mtdblock$i > mtdblock$i.bin; done

mtd_write -r -e mtd0 write u-boot-nexx-3020-7620.bin mtd0

После этого роутер должен перезагрузиться с новым загрузчиком, но со старой прошивкой. После выполнения этого шага питание от роутера можно отключить.

Чтобы попасть в загрузчик теперь необходимо зажать кнопку сброса и включить роутер. Подержать 3 секунды и загрузчик запустится в режиме http-сервера на 192.168.1.1. Затем в вэб интерфейсе загрузчика идем по пути Firmware Upgrade, ставим птичку на пункте Firmware, нажимаем Browse и ищем на диске нашу прошивку openwrt-15.05-ramips-mt7620-wt3020-8M-squashfs-sysupgrade.bin и потом Upload. Загрузчик считает прошивку и зеленым цветом известит нас что все в порядке и можно прошиваться. Этот процесс займет пару минут и роутер опять перегрузится. Далее можно заходить браузером по адресу 192.168.1.1 в вэб интерфейс OpenWrt для дальнейшей настройки. Логин по умолчанию root. Пароль придумаете сами. Этот пароль будет использоваться для доступа к роутеру по SSH.

В вэб интерфейсе OpenWrt настроить wifi как клиент. Т.к роутер в дальнейшем будет скачивать с инета пакеты для работы.

1. Зайдем через SSH под рутом по адресу 192.168.1.1 и поставить недостающие пакеты

opkg update
opkg install kmod-sound-core kmod-usb-audio kmod-input-core kmod-input-evdev madplay alsa-utils triggerhappy kmod-hid kmod-usb-hid

3. Выложить содержимое приложенного архива radio.zip в корень файловой системы роутера
4. Поставить права доступа на скрипты

chmod 755 /etc/init.d/webradio
chmod 755 /www/cgi-bin/webradio/items.cgi
chmod 755 /www/cgi-bin/webradio/update.cgi
chmod 755 /www/scripts/getstreammeta.sh
chmod 755 /www/scripts/playback.sh
chmod 755 /www/scripts/playstream.sh
chmod 755 /www/scripts/stopstream.sh
chmod 755 /www/scripts/streamcontrol.sh
chmod 755 /www/scripts/webradio.sh

5. Включить triggerhappy и радио в автозагрузку

/etc/init.d/triggerhappy enable
/etc/init.d/webradio enable

6. Перезагрузить роутер и если все сделано правильно, то по адресу

появится простой веб-интерфейс для управления радио и начнется воспроизведение первой станции из списка.

С помощью элементов управления можно менять позицию той или иной станции, удалять станцию, добавлять станцию. При этом ее название автоматически будет добавляться в каталог.
Нажимая кнопки Vol+ и Vol- можно менять громкость станции, а кнопкой Mute переключать станции вперед по кольцу. Название станции будет проговаривать синтезатор голоса.

Загрузчик менял по методу изложенному в этом посте.

Т.к. у меня клон Hame mpr-a1 с флэш 4 мб, то прошить в лоб стандартный пакет Openwrt и потом вручную установить пакеты как в посте выше просто не получится. В флэш памяти моего роутера не хватает места. Поэтому пришлось собрать прошивку с уже внедренными пакетами.

Прошивку можно скачать по этой ссылке.

Прошивка заливается в роутер с помощью китайской утилиты.

Затем по телнет на адрес 192.168.1.1 и ввести команду passwd. Вводим новый пароль. Теперь можно заходить на роутер с помощью WinSCP. На роутере надо поднять wifi. Для этого в каталоге /etc/config меняем содержимое файла network :

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

Читать еще:  Безлимитный интернет для вай фай роутера

config globals ‘globals’
option ula_prefix ‘fd85:d10f:62c9::/48’

config interface ‘lan’
option ifname ‘eth0.1’
option type ‘bridge’
option proto ‘static’
option gateway ‘192.168.1.1’
option dns ‘77.88.8.7’
option netmask ‘255.255.255.0’
option ip6assign ’60’
option ipaddr ‘192.168.100.100’

config interface ‘wan’
option ifname ‘eth0.2’
option proto ‘dhcp’
option type ‘bridge’
option metric ’50’

config switch
option name ‘rt305x’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘rt305x’
option vlan ‘2’
option ports ‘4 6t’

config switch_vlan
option device ‘rt305x’
option vlan ‘1’
option ports ‘0 6t’

config interface ‘modem_usb’
option proto ‘dhcp’
option ifname ‘usb0’
option metric ‘100’

config interface ‘wwan’
option dns ‘8.8.8.8’
option proto ‘static’
option ipaddr ‘192.168.1.100’
option netmask ‘255.255.255.0’
option gateway ‘192.168.1.1’

config wifi-device ‘radio0’
option type ‘mac80211’
option hwmode ’11g’
option path ‘10180000.wmac’
option htmode ‘HT20’
option disabled ‘0’
option channel ‘auto’
option country ‘RU’

config wifi-iface
option device ‘radio0’
option mode ‘sta’
option network ‘wwan’
option ssid ‘НАЗВАНИЕ ВАШЕЙ WI-FI СЕТИ ‘
option key ‘ПАРОЛЬ ВАШЕЙ WI-FI СЕТИ ‘
option encryption ‘psk2+aes’

Командой wifi up включаем wifi на роутере. Немного подождем, если синий светодиод на роутере начнет мигать, то все OK.

Роутер можно перезагрузить и доступ к роутеру теперь будет по wifi по адресу 192.168.1.100. По lan можно зайти по адресу 192.168.100.100.

Hame MPR-A1 и клоны на чипе RT5350 (4 мб флэш)

Tplink tl-wr710v2.0 (4мб флэш)

Мануал от samur005 ( для прошивки «Хитрый Домовенок» )

Сообщение отредактировал ctich — 19.02.17, 22:12

Приветствую. К сожалению, я не сильный электронщик. Нарыл только в гугле это и это. И еще можно посмотреть на специализированных форумах.

Да не, тут вопрос не в программировании и не в даташите. Есть подозрение, что под openwrt уже и i2s драйвер есть. Например, в 15.05 есть пакет kmod-sound-mt7620, что вполне может оказаться одним из требуемых пакетов. а вот как оно шаг за шагом подключается и были ли успешные реализации подключения — не понятно. И сведения обрывочные только попадаются, что не могу полную картину воссоздать.
Для платформы ar9331 (tp-link mr3020) китайцы драйверы написали, когда создавали свой airmusic. А тут, вроде, и поддержка i2s изначально есть в процессоре, а полного мануала (по программной части) подключения dac по i2s шине нигде нет. Было бы здорово обойтись без ненужного преобразования через usb. И порт остался бы свободен.

Ладно, в общем, понял, не встречали. Будем искать.

Чем плохо такое преобразование ? Вносятся шумы, искажения при воспроизведении аудио ?

Шумы вряд, это ж цифра. USB конвертер сужает возможности ЦАП по битности и частоте дискретизации. Кроме, того, очень существенно добавляет стоимости к конечному продукту (звуковой карте). Предложений ЦАП без конвертера USB масса — от Китая до «аудиофильских» платок к малинке. После покупки именитой Creative SB Play, как раз для целей подключения к роутеру, в звукашках «от брендов» я совсем разочаровался, ибо ЦАП там древний, как экскременты мамонта. Звук соответствующий.

Если из схемы выбросить USB звук и пересадить его на шину i2s, будет порт usb свободен (флешка для музыки) и можно не использовать USB хаб (он надежности не добавляет, из-за него возможны зависания). В общем, одни плюсы)

На wt3020 процессор mt7620n, на нем, похоже, линии i2s отключены. Доступны они на mt7620a, в xiaomi, но этот роутер пока новый, его никто особо не ковырял.

Спасибо, все работает,
На клоне HAME
Как бы еще добавить регулировку громкости и стоп произведения из веб морды? Звуковая к сожалению без кнопок.

Сообщение отредактировал D_MitriY — 17.03.16, 15:27

Если нужна громкость и кнопка выключения в вэб интерфейсе могу рекомендовать этот проект. Прошивка для RT5350 здесь.
Можно попробовать и скрестить.

Сообщение отредактировал sergej_a_g — 17.03.16, 19:59

Wi-Fi радио с интернетом своими руками: пошаговая инструкция

Привет, дорогой радиолюбитель! Сегодня мы поговорим, о том, как можно полноценно сделать WiFi Radio своими руками. Проблема встала, когда на работе появилась задача – слушать музыку и была возможность подключить по Wi-Fi. На самом деле подобные радиоприёмники продаются в интернете и магазинах. Также есть альтернатива обычного подключения телефона к Bluetooth колонки или к обычной аудио системе – разницы нет.

Ко мне на борт попал старый роутер, у которого перегорело пара портов. Также со старых времен у меня осталась старая могнитола, которую также можно было использовать. Далее из всех контроллеров, который можно использовать – я выбрал именно Stellaris. Почему я выбрал корпус именно от магнитолы? – Дело в том, что большинство делают именно из фанеры. Сразу скажу, что это как хороший, так и ужасный вариант в некоторых условиях.

Например, если вы будете делать подобное устройство на кухню или в место, где есть повышенная влажность, то лучше делать из подобных пластиковых материалов. Фанеру от влаги может повести. Также при нормальной ровности рук, можно использовать кнопки от старого аппарата в действие.

В качестве интерфейса и управления я выбрал именно небольшой экран. Для переключения радиостанции будут две кнопки. Аналогичные будут и для уровня звука. А теперь самое главное – где взять полноценную инструкцию. Я не стал изобретать велосипед и сделал все по канону.

В данной статье я не буду расписывать все по шагам, так как инструкция уже есть тут . Там все по шагам объяснено и достаточно понятно. Кто не знает английского можете воспользоваться переводчиком Google Chrome. В качестве управления я использовал именно микроконтроллер.

Сборка

Начнем, наверное, со Stellaris, который нужно связать с компьютером через UART порт. Их всего 6 штук. На нулевой нужно будет пробросить связь с ПК, а вот на 1 UART порт надо будет сделать связь с роутером, который будет у нас связующим с беспроводной сетью. Также вся это конструкция должна хранить полный плей-лист станций внутри памяти. Для этого можно использовать память роутера.

Читать еще:  Безлимитный интернет через роутер

Из старой магнитолы вытаскиваем все кроме динамиков. Ну по крайней мере я сделал именно так. Если есть время, то можете сохранить усилитель. Далее я делал все по той же схеме, используя дополнительные детали. Некоторые детали покупал на eBay, а какие-то просто получило от знакомых. В общем аппарат получился по цене примерно на 3000 рублей.

Если брать в магазинах, то подобное радио стоит от 5000 рублей. Достаточно дорого – но тут все связано именно с популярностью. Подобный аудиа-передатчики с Wi-Fi на сегодняшний момент очень непопулярны. Так как большинство людей пользуются именно беспроводными колонками. В некоторых случаях, это удобнее и практичнее.

Для покупателей

Если вы прочли все это и поняли, что лучше потратить деньги и купить себе радио с интернетом – то вы можете посмотреть мой обзор самых лучших моделей тут. Там представлено несколько моделей, а также советы по выбору.

Все необходимое для самостоятельной сборки Web-радиоприемника

Вы могли слышать про популярные радиоприемники, которые получают сигнал трансляций из интернета. Для работы подобного устройства не нужна радиотрансляционная вышка — только домашний Wi-Fi. Умельцы стилизуют свои самодельные Web-радиоприемники под олд-скульную и винтажную технику. А готовые устройства стоят весьма не скромно. В этой статье расскажу, как самостоятельно собрать интернет-радио с минимальными затратами.

Для сборки вам потребуется:
1. Источник питания (от 5 до 24 В). Пойдут старые блоки питания от гаджетов, ноутбуков и так далее. Возможно потребуется отдельный преобразователь для контроллера (для понижения с 24 до 5 В).

2. Корпус. Можно использовать старые корпуса от гаджетов, старой аудио-видео техники. Хороший вариант — встроить контроллер в активные компьютерные колонки — приличный вид плюс усилитель, динамики и источник питания. Можно сделать корпус с нуля — из пластика, ДСП, картона и т.п. Основная проблема будет — сделать аккуратную переднюю панель.

3. Контроллер для интернет радио. Это модуль с Wi-Fi и открытой прошивкой. Можно использовать роутер с Open-WRT, можно отдельный контроллер на ESP32/8266. Желательно брать сразу с дисплеем, так как будет компактнее и проще готовое изделие.

4. Аудиомодуль и аудиоусилитель. Если контроллер не имеет встроенной микросхемы для вывода звука, то лучше приобрести отдельный ЦАП с интерфейсом I2S. Потребуется также и усилитель звука для вывода на мощные колонки.

5. Динамики или колонки. Самый простой вариант — колонки от портативной акустики, это компактные и широкополосные варианты на 2″ или 3″.

6. Прямые руки для того, чтобы собрать все вместе, спаять, залить прошивку, IP адреса вещания, а также придать приличный внешний вид готовому устройству.

Контроллеров несколько, на выбор. Самый простой вариант (Kit8) стоит около $4.9, вариант с дисплеем побольше (T-Display) около $10, но обратите также внимание на функциональные варианты, например, T-Audio со встроенным ЦАП-ом.

Это, наверное, самый простой вариант (Wi-Fi Web Kit8) — модуль на базе NodeMCU/ESP-8266 со встроенным дисплеем и USB интерфейсом. Подходит не только для проектов интернет-радио, но и для самодельных RC-моделей, для умного дома, IoT и так далее. Модуль предусматривает несколько дискретных входов-выходов, а также аналоговый (А0).

Неплохой вариант — контроллеры от TTGO. Этот вариант чут-чуть подороже, но и экран побольше. Модуль может быть интереснее, как управляющий модуль для интернет радио. На экране можно выбирать нужную «радио-волну», а кнопками подтверждать выбор. Аналогично предыдущей плате, модуль имеет интерфейс USB.

Достаточно дорогой, но популярный модуль TTGO T5s. Версия платы V2.1, остнован на ESP32 и огромном 2,7″ дисплее Е-ink (E-Paper). Модуль имеет встроенный микрофон, ЦАП МAX98357A, ридер SD карты, bluetooth. Это одно из готовых решений для интернет-радио.

Самый фукциональный модуль от TTGO, заточенный под воспроизведение аудио. Это T-Audio (альтернативное название WROVER ESP32). Имеет интересную круглую форму платы под портативные колонки — как раз вариант под самодельный корпус из водопроводной трубы. На плате расположен ридер SD карт, bluetooth, WI-FI, ЦАП WM8978, светодиод WS2812B RGB и акселерометр MPU9250.

Последние два модуля имеют встроенный ЦАП, а для остальных следует приобрести отдельный шилд с микросхемой для вывода звука (I2S DAC). Эти шилды заточен под вывод звука с контролера через интерфейс I2S (стандартный). Из цифрового потока в аудио преобразование выполняет специальный ЦАП PCM5102.

В первом лоте есть в комплекте передняя панель, останется найти только коробку. По качеству неплохие и громкие (широкополосные). Вторые динамики совсем дешевые ($2), но пойдут для пробы.

Недорогой усилитель PAM8610 с двумя выходами по 2х10 Вт — пригодится для усиления звука на динамики. Это самые популярный и недорогой усилитель сигнала класса D. Подключение проблем не вызывает — правый/левый каналы, питание, динамики.

Недорогой усилитель PAM8610 с двумя выходами по 2х10 Вт с регулировкой звука. Такой же, как и предыдущий, недорогой, но с распаянным фильтром и коннекторами для удобства. Я рекомендую именно такой, особенно если есть возможность расположить все в корпусе.

Корпус можно собрать из подручных материалов — взять старую коробку из-под устройств, компьютерные колонки, старые DVD плееры или радиоприемники.

Все указанные модули прошиваются из Arduino. Прошивки открытые.

Если честно, то это одни из лучших проектов для самостоятельно сборки. Очень полезное применение недорогих комплектующих, паяльника и своего времени. Если вы пытаетесь увлечь сына программированию, то это простой и наглядный способ рассказать что и как. Если вы подбираете проект для школы или института, то тоже рекомендую обратить внимание, так как подобные проекты в последнее время наиболее актуальны.

Ссылка на основную публикацию
Adblock
detector