Naautsorse.ru

Связь и коммуникации
11 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Интернет радио из роутера

Интернет радио из роутера

Сообщение отредактировал emirov84 — 21.12.16, 14:21

Какие модели мобильных роутеров можно использовать для создания wifi интернет радио ?

1) Nexx WT3020H(F) ( флэш память 8 мб, ОЗУ- 64 мб )
2) Xiaomi Mi-router mini
3) Клоны Hame MPR-A1 на чипе RT5350 ( у меня клон с флэш 4 мб, ОЗУ-32 мб )
4) GL-MT300N ( флэш память 16 мб, ОЗУ- 64 мб )

Выбор операционной системы.

Выбор дополнительного оборудования.

1) Внешняя аудиокарта с кнопками для управления.
2) USB наушники с кнопками для управления
3) Портативная аудиоклонка

С помощью шнурка подсоеденить роутер (вход Lan на роутере) к сетевой карте компьютера.

Прежде чем заливать прошивку, поменяем загрузчик на U-boot. Файл загрузчика скачаем отсюда. Затем будем делать по шагам :

1.Записываем на флэшку u-boot-nexx-3020-7620.bin
2. Подключаем ее в роутер
3. Заходим на роутер по телнет на адрес 192.168.8.1 с логином nexxadmin и паролем y1n2inc.com0755
4. Вводим в командной строке

5. На всякий случай сделаем бэкап

for i in 0 1 2 3; do cat /dev/mtdblock$i > mtdblock$i.bin; done

mtd_write -r -e mtd0 write u-boot-nexx-3020-7620.bin mtd0

После этого роутер должен перезагрузиться с новым загрузчиком, но со старой прошивкой. После выполнения этого шага питание от роутера можно отключить.

Чтобы попасть в загрузчик теперь необходимо зажать кнопку сброса и включить роутер. Подержать 3 секунды и загрузчик запустится в режиме http-сервера на 192.168.1.1. Затем в вэб интерфейсе загрузчика идем по пути Firmware Upgrade, ставим птичку на пункте Firmware, нажимаем Browse и ищем на диске нашу прошивку openwrt-15.05-ramips-mt7620-wt3020-8M-squashfs-sysupgrade.bin и потом Upload. Загрузчик считает прошивку и зеленым цветом известит нас что все в порядке и можно прошиваться. Этот процесс займет пару минут и роутер опять перегрузится. Далее можно заходить браузером по адресу 192.168.1.1 в вэб интерфейс OpenWrt для дальнейшей настройки. Логин по умолчанию root. Пароль придумаете сами. Этот пароль будет использоваться для доступа к роутеру по SSH.

В вэб интерфейсе OpenWrt настроить wifi как клиент. Т.к роутер в дальнейшем будет скачивать с инета пакеты для работы.

1. Зайдем через SSH под рутом по адресу 192.168.1.1 и поставить недостающие пакеты

opkg update
opkg install kmod-sound-core kmod-usb-audio kmod-input-core kmod-input-evdev madplay alsa-utils triggerhappy kmod-hid kmod-usb-hid

3. Выложить содержимое приложенного архива radio.zip в корень файловой системы роутера
4. Поставить права доступа на скрипты

chmod 755 /etc/init.d/webradio
chmod 755 /www/cgi-bin/webradio/items.cgi
chmod 755 /www/cgi-bin/webradio/update.cgi
chmod 755 /www/scripts/getstreammeta.sh
chmod 755 /www/scripts/playback.sh
chmod 755 /www/scripts/playstream.sh
chmod 755 /www/scripts/stopstream.sh
chmod 755 /www/scripts/streamcontrol.sh
chmod 755 /www/scripts/webradio.sh

5. Включить triggerhappy и радио в автозагрузку

/etc/init.d/triggerhappy enable
/etc/init.d/webradio enable

6. Перезагрузить роутер и если все сделано правильно, то по адресу

появится простой веб-интерфейс для управления радио и начнется воспроизведение первой станции из списка.

С помощью элементов управления можно менять позицию той или иной станции, удалять станцию, добавлять станцию. При этом ее название автоматически будет добавляться в каталог.
Нажимая кнопки Vol+ и Vol- можно менять громкость станции, а кнопкой Mute переключать станции вперед по кольцу. Название станции будет проговаривать синтезатор голоса.

Загрузчик менял по методу изложенному в этом посте.

Т.к. у меня клон Hame mpr-a1 с флэш 4 мб, то прошить в лоб стандартный пакет Openwrt и потом вручную установить пакеты как в посте выше просто не получится. В флэш памяти моего роутера не хватает места. Поэтому пришлось собрать прошивку с уже внедренными пакетами.

Прошивку можно скачать по этой ссылке.

Прошивка заливается в роутер с помощью китайской утилиты.

Затем по телнет на адрес 192.168.1.1 и ввести команду passwd. Вводим новый пароль. Теперь можно заходить на роутер с помощью WinSCP. На роутере надо поднять wifi. Для этого в каталоге /etc/config меняем содержимое файла network :

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd85:d10f:62c9::/48’

config interface ‘lan’
option ifname ‘eth0.1’
option type ‘bridge’
option proto ‘static’
option gateway ‘192.168.1.1’
option dns ‘77.88.8.7’
option netmask ‘255.255.255.0’
option ip6assign ’60’
option ipaddr ‘192.168.100.100’

config interface ‘wan’
option ifname ‘eth0.2’
option proto ‘dhcp’
option type ‘bridge’
option metric ’50’

config switch
option name ‘rt305x’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘rt305x’
option vlan ‘2’
option ports ‘4 6t’

config switch_vlan
option device ‘rt305x’
option vlan ‘1’
option ports ‘0 6t’

config interface ‘modem_usb’
option proto ‘dhcp’
option ifname ‘usb0’
option metric ‘100’

config interface ‘wwan’
option dns ‘8.8.8.8’
option proto ‘static’
option ipaddr ‘192.168.1.100’
option netmask ‘255.255.255.0’
option gateway ‘192.168.1.1’

config wifi-device ‘radio0’
option type ‘mac80211’
option hwmode ’11g’
option path ‘10180000.wmac’
option htmode ‘HT20’
option disabled ‘0’
option channel ‘auto’
option country ‘RU’

config wifi-iface
option device ‘radio0’
option mode ‘sta’
option network ‘wwan’
option ssid ‘НАЗВАНИЕ ВАШЕЙ WI-FI СЕТИ ‘
option key ‘ПАРОЛЬ ВАШЕЙ WI-FI СЕТИ ‘
option encryption ‘psk2+aes’

Командой wifi up включаем wifi на роутере. Немного подождем, если синий светодиод на роутере начнет мигать, то все OK.

Роутер можно перезагрузить и доступ к роутеру теперь будет по wifi по адресу 192.168.1.100. По lan можно зайти по адресу 192.168.100.100.

Hame MPR-A1 и клоны на чипе RT5350 (4 мб флэш)

Tplink tl-wr710v2.0 (4мб флэш)

Мануал от samur005 ( для прошивки «Хитрый Домовенок» )

Сообщение отредактировал ctich — 19.02.17, 22:12

Приветствую. К сожалению, я не сильный электронщик. Нарыл только в гугле это и это. И еще можно посмотреть на специализированных форумах.

Да не, тут вопрос не в программировании и не в даташите. Есть подозрение, что под openwrt уже и i2s драйвер есть. Например, в 15.05 есть пакет kmod-sound-mt7620, что вполне может оказаться одним из требуемых пакетов. а вот как оно шаг за шагом подключается и были ли успешные реализации подключения — не понятно. И сведения обрывочные только попадаются, что не могу полную картину воссоздать.
Для платформы ar9331 (tp-link mr3020) китайцы драйверы написали, когда создавали свой airmusic. А тут, вроде, и поддержка i2s изначально есть в процессоре, а полного мануала (по программной части) подключения dac по i2s шине нигде нет. Было бы здорово обойтись без ненужного преобразования через usb. И порт остался бы свободен.

Ладно, в общем, понял, не встречали. Будем искать.

Чем плохо такое преобразование ? Вносятся шумы, искажения при воспроизведении аудио ?

Шумы вряд, это ж цифра. USB конвертер сужает возможности ЦАП по битности и частоте дискретизации. Кроме, того, очень существенно добавляет стоимости к конечному продукту (звуковой карте). Предложений ЦАП без конвертера USB масса — от Китая до «аудиофильских» платок к малинке. После покупки именитой Creative SB Play, как раз для целей подключения к роутеру, в звукашках «от брендов» я совсем разочаровался, ибо ЦАП там древний, как экскременты мамонта. Звук соответствующий.

Читать еще:  Билайн роутер для домашнего интернета и тв

Если из схемы выбросить USB звук и пересадить его на шину i2s, будет порт usb свободен (флешка для музыки) и можно не использовать USB хаб (он надежности не добавляет, из-за него возможны зависания). В общем, одни плюсы)

На wt3020 процессор mt7620n, на нем, похоже, линии i2s отключены. Доступны они на mt7620a, в xiaomi, но этот роутер пока новый, его никто особо не ковырял.

Спасибо, все работает,
На клоне HAME
Как бы еще добавить регулировку громкости и стоп произведения из веб морды? Звуковая к сожалению без кнопок.

Сообщение отредактировал D_MitriY — 17.03.16, 15:27

Если нужна громкость и кнопка выключения в вэб интерфейсе могу рекомендовать этот проект. Прошивка для RT5350 здесь.
Можно попробовать и скрестить.

Сообщение отредактировал sergej_a_g — 17.03.16, 19:59

Интернет радио из роутера

Сообщение отредактировал emirov84 — 21.12.16, 14:21

Какие модели мобильных роутеров можно использовать для создания wifi интернет радио ?

1) Nexx WT3020H(F) ( флэш память 8 мб, ОЗУ- 64 мб )
2) Xiaomi Mi-router mini
3) Клоны Hame MPR-A1 на чипе RT5350 ( у меня клон с флэш 4 мб, ОЗУ-32 мб )
4) GL-MT300N ( флэш память 16 мб, ОЗУ- 64 мб )

Выбор операционной системы.

Выбор дополнительного оборудования.

1) Внешняя аудиокарта с кнопками для управления.
2) USB наушники с кнопками для управления
3) Портативная аудиоклонка

С помощью шнурка подсоеденить роутер (вход Lan на роутере) к сетевой карте компьютера.

Прежде чем заливать прошивку, поменяем загрузчик на U-boot. Файл загрузчика скачаем отсюда. Затем будем делать по шагам :

1.Записываем на флэшку u-boot-nexx-3020-7620.bin
2. Подключаем ее в роутер
3. Заходим на роутер по телнет на адрес 192.168.8.1 с логином nexxadmin и паролем y1n2inc.com0755
4. Вводим в командной строке

5. На всякий случай сделаем бэкап

for i in 0 1 2 3; do cat /dev/mtdblock$i > mtdblock$i.bin; done

mtd_write -r -e mtd0 write u-boot-nexx-3020-7620.bin mtd0

После этого роутер должен перезагрузиться с новым загрузчиком, но со старой прошивкой. После выполнения этого шага питание от роутера можно отключить.

Чтобы попасть в загрузчик теперь необходимо зажать кнопку сброса и включить роутер. Подержать 3 секунды и загрузчик запустится в режиме http-сервера на 192.168.1.1. Затем в вэб интерфейсе загрузчика идем по пути Firmware Upgrade, ставим птичку на пункте Firmware, нажимаем Browse и ищем на диске нашу прошивку openwrt-15.05-ramips-mt7620-wt3020-8M-squashfs-sysupgrade.bin и потом Upload. Загрузчик считает прошивку и зеленым цветом известит нас что все в порядке и можно прошиваться. Этот процесс займет пару минут и роутер опять перегрузится. Далее можно заходить браузером по адресу 192.168.1.1 в вэб интерфейс OpenWrt для дальнейшей настройки. Логин по умолчанию root. Пароль придумаете сами. Этот пароль будет использоваться для доступа к роутеру по SSH.

В вэб интерфейсе OpenWrt настроить wifi как клиент. Т.к роутер в дальнейшем будет скачивать с инета пакеты для работы.

1. Зайдем через SSH под рутом по адресу 192.168.1.1 и поставить недостающие пакеты

opkg update
opkg install kmod-sound-core kmod-usb-audio kmod-input-core kmod-input-evdev madplay alsa-utils triggerhappy kmod-hid kmod-usb-hid

3. Выложить содержимое приложенного архива radio.zip в корень файловой системы роутера
4. Поставить права доступа на скрипты

chmod 755 /etc/init.d/webradio
chmod 755 /www/cgi-bin/webradio/items.cgi
chmod 755 /www/cgi-bin/webradio/update.cgi
chmod 755 /www/scripts/getstreammeta.sh
chmod 755 /www/scripts/playback.sh
chmod 755 /www/scripts/playstream.sh
chmod 755 /www/scripts/stopstream.sh
chmod 755 /www/scripts/streamcontrol.sh
chmod 755 /www/scripts/webradio.sh

5. Включить triggerhappy и радио в автозагрузку

/etc/init.d/triggerhappy enable
/etc/init.d/webradio enable

6. Перезагрузить роутер и если все сделано правильно, то по адресу

появится простой веб-интерфейс для управления радио и начнется воспроизведение первой станции из списка.

С помощью элементов управления можно менять позицию той или иной станции, удалять станцию, добавлять станцию. При этом ее название автоматически будет добавляться в каталог.
Нажимая кнопки Vol+ и Vol- можно менять громкость станции, а кнопкой Mute переключать станции вперед по кольцу. Название станции будет проговаривать синтезатор голоса.

Загрузчик менял по методу изложенному в этом посте.

Т.к. у меня клон Hame mpr-a1 с флэш 4 мб, то прошить в лоб стандартный пакет Openwrt и потом вручную установить пакеты как в посте выше просто не получится. В флэш памяти моего роутера не хватает места. Поэтому пришлось собрать прошивку с уже внедренными пакетами.

Прошивку можно скачать по этой ссылке.

Прошивка заливается в роутер с помощью китайской утилиты.

Затем по телнет на адрес 192.168.1.1 и ввести команду passwd. Вводим новый пароль. Теперь можно заходить на роутер с помощью WinSCP. На роутере надо поднять wifi. Для этого в каталоге /etc/config меняем содержимое файла network :

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd85:d10f:62c9::/48’

config interface ‘lan’
option ifname ‘eth0.1’
option type ‘bridge’
option proto ‘static’
option gateway ‘192.168.1.1’
option dns ‘77.88.8.7’
option netmask ‘255.255.255.0’
option ip6assign ’60’
option ipaddr ‘192.168.100.100’

config interface ‘wan’
option ifname ‘eth0.2’
option proto ‘dhcp’
option type ‘bridge’
option metric ’50’

config switch
option name ‘rt305x’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘rt305x’
option vlan ‘2’
option ports ‘4 6t’

config switch_vlan
option device ‘rt305x’
option vlan ‘1’
option ports ‘0 6t’

config interface ‘modem_usb’
option proto ‘dhcp’
option ifname ‘usb0’
option metric ‘100’

config interface ‘wwan’
option dns ‘8.8.8.8’
option proto ‘static’
option ipaddr ‘192.168.1.100’
option netmask ‘255.255.255.0’
option gateway ‘192.168.1.1’

config wifi-device ‘radio0’
option type ‘mac80211’
option hwmode ’11g’
option path ‘10180000.wmac’
option htmode ‘HT20’
option disabled ‘0’
option channel ‘auto’
option country ‘RU’

config wifi-iface
option device ‘radio0’
option mode ‘sta’
option network ‘wwan’
option ssid ‘НАЗВАНИЕ ВАШЕЙ WI-FI СЕТИ ‘
option key ‘ПАРОЛЬ ВАШЕЙ WI-FI СЕТИ ‘
option encryption ‘psk2+aes’

Командой wifi up включаем wifi на роутере. Немного подождем, если синий светодиод на роутере начнет мигать, то все OK.

Роутер можно перезагрузить и доступ к роутеру теперь будет по wifi по адресу 192.168.1.100. По lan можно зайти по адресу 192.168.100.100.

Hame MPR-A1 и клоны на чипе RT5350 (4 мб флэш)

Tplink tl-wr710v2.0 (4мб флэш)

Мануал от samur005 ( для прошивки «Хитрый Домовенок» )

Сообщение отредактировал ctich — 19.02.17, 22:12

Приветствую. К сожалению, я не сильный электронщик. Нарыл только в гугле это и это. И еще можно посмотреть на специализированных форумах.

Да не, тут вопрос не в программировании и не в даташите. Есть подозрение, что под openwrt уже и i2s драйвер есть. Например, в 15.05 есть пакет kmod-sound-mt7620, что вполне может оказаться одним из требуемых пакетов. а вот как оно шаг за шагом подключается и были ли успешные реализации подключения — не понятно. И сведения обрывочные только попадаются, что не могу полную картину воссоздать.
Для платформы ar9331 (tp-link mr3020) китайцы драйверы написали, когда создавали свой airmusic. А тут, вроде, и поддержка i2s изначально есть в процессоре, а полного мануала (по программной части) подключения dac по i2s шине нигде нет. Было бы здорово обойтись без ненужного преобразования через usb. И порт остался бы свободен.

Читать еще:  Безлимитный интернет через роутер

Ладно, в общем, понял, не встречали. Будем искать.

Чем плохо такое преобразование ? Вносятся шумы, искажения при воспроизведении аудио ?

Шумы вряд, это ж цифра. USB конвертер сужает возможности ЦАП по битности и частоте дискретизации. Кроме, того, очень существенно добавляет стоимости к конечному продукту (звуковой карте). Предложений ЦАП без конвертера USB масса — от Китая до «аудиофильских» платок к малинке. После покупки именитой Creative SB Play, как раз для целей подключения к роутеру, в звукашках «от брендов» я совсем разочаровался, ибо ЦАП там древний, как экскременты мамонта. Звук соответствующий.

Если из схемы выбросить USB звук и пересадить его на шину i2s, будет порт usb свободен (флешка для музыки) и можно не использовать USB хаб (он надежности не добавляет, из-за него возможны зависания). В общем, одни плюсы)

На wt3020 процессор mt7620n, на нем, похоже, линии i2s отключены. Доступны они на mt7620a, в xiaomi, но этот роутер пока новый, его никто особо не ковырял.

Спасибо, все работает,
На клоне HAME
Как бы еще добавить регулировку громкости и стоп произведения из веб морды? Звуковая к сожалению без кнопок.

Сообщение отредактировал D_MitriY — 17.03.16, 15:27

Если нужна громкость и кнопка выключения в вэб интерфейсе могу рекомендовать этот проект. Прошивка для RT5350 здесь.
Можно попробовать и скрестить.

Сообщение отредактировал sergej_a_g — 17.03.16, 19:59

Интернет радио из роутера

Сообщение отредактировал emirov84 — 21.12.16, 14:21

Какие модели мобильных роутеров можно использовать для создания wifi интернет радио ?

1) Nexx WT3020H(F) ( флэш память 8 мб, ОЗУ- 64 мб )
2) Xiaomi Mi-router mini
3) Клоны Hame MPR-A1 на чипе RT5350 ( у меня клон с флэш 4 мб, ОЗУ-32 мб )
4) GL-MT300N ( флэш память 16 мб, ОЗУ- 64 мб )

Выбор операционной системы.

Выбор дополнительного оборудования.

1) Внешняя аудиокарта с кнопками для управления.
2) USB наушники с кнопками для управления
3) Портативная аудиоклонка

С помощью шнурка подсоеденить роутер (вход Lan на роутере) к сетевой карте компьютера.

Прежде чем заливать прошивку, поменяем загрузчик на U-boot. Файл загрузчика скачаем отсюда. Затем будем делать по шагам :

1.Записываем на флэшку u-boot-nexx-3020-7620.bin
2. Подключаем ее в роутер
3. Заходим на роутер по телнет на адрес 192.168.8.1 с логином nexxadmin и паролем y1n2inc.com0755
4. Вводим в командной строке

5. На всякий случай сделаем бэкап

for i in 0 1 2 3; do cat /dev/mtdblock$i > mtdblock$i.bin; done

mtd_write -r -e mtd0 write u-boot-nexx-3020-7620.bin mtd0

После этого роутер должен перезагрузиться с новым загрузчиком, но со старой прошивкой. После выполнения этого шага питание от роутера можно отключить.

Чтобы попасть в загрузчик теперь необходимо зажать кнопку сброса и включить роутер. Подержать 3 секунды и загрузчик запустится в режиме http-сервера на 192.168.1.1. Затем в вэб интерфейсе загрузчика идем по пути Firmware Upgrade, ставим птичку на пункте Firmware, нажимаем Browse и ищем на диске нашу прошивку openwrt-15.05-ramips-mt7620-wt3020-8M-squashfs-sysupgrade.bin и потом Upload. Загрузчик считает прошивку и зеленым цветом известит нас что все в порядке и можно прошиваться. Этот процесс займет пару минут и роутер опять перегрузится. Далее можно заходить браузером по адресу 192.168.1.1 в вэб интерфейс OpenWrt для дальнейшей настройки. Логин по умолчанию root. Пароль придумаете сами. Этот пароль будет использоваться для доступа к роутеру по SSH.

В вэб интерфейсе OpenWrt настроить wifi как клиент. Т.к роутер в дальнейшем будет скачивать с инета пакеты для работы.

1. Зайдем через SSH под рутом по адресу 192.168.1.1 и поставить недостающие пакеты

opkg update
opkg install kmod-sound-core kmod-usb-audio kmod-input-core kmod-input-evdev madplay alsa-utils triggerhappy kmod-hid kmod-usb-hid

3. Выложить содержимое приложенного архива radio.zip в корень файловой системы роутера
4. Поставить права доступа на скрипты

chmod 755 /etc/init.d/webradio
chmod 755 /www/cgi-bin/webradio/items.cgi
chmod 755 /www/cgi-bin/webradio/update.cgi
chmod 755 /www/scripts/getstreammeta.sh
chmod 755 /www/scripts/playback.sh
chmod 755 /www/scripts/playstream.sh
chmod 755 /www/scripts/stopstream.sh
chmod 755 /www/scripts/streamcontrol.sh
chmod 755 /www/scripts/webradio.sh

5. Включить triggerhappy и радио в автозагрузку

/etc/init.d/triggerhappy enable
/etc/init.d/webradio enable

6. Перезагрузить роутер и если все сделано правильно, то по адресу

появится простой веб-интерфейс для управления радио и начнется воспроизведение первой станции из списка.

С помощью элементов управления можно менять позицию той или иной станции, удалять станцию, добавлять станцию. При этом ее название автоматически будет добавляться в каталог.
Нажимая кнопки Vol+ и Vol- можно менять громкость станции, а кнопкой Mute переключать станции вперед по кольцу. Название станции будет проговаривать синтезатор голоса.

Загрузчик менял по методу изложенному в этом посте.

Т.к. у меня клон Hame mpr-a1 с флэш 4 мб, то прошить в лоб стандартный пакет Openwrt и потом вручную установить пакеты как в посте выше просто не получится. В флэш памяти моего роутера не хватает места. Поэтому пришлось собрать прошивку с уже внедренными пакетами.

Прошивку можно скачать по этой ссылке.

Прошивка заливается в роутер с помощью китайской утилиты.

Затем по телнет на адрес 192.168.1.1 и ввести команду passwd. Вводим новый пароль. Теперь можно заходить на роутер с помощью WinSCP. На роутере надо поднять wifi. Для этого в каталоге /etc/config меняем содержимое файла network :

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd85:d10f:62c9::/48’

config interface ‘lan’
option ifname ‘eth0.1’
option type ‘bridge’
option proto ‘static’
option gateway ‘192.168.1.1’
option dns ‘77.88.8.7’
option netmask ‘255.255.255.0’
option ip6assign ’60’
option ipaddr ‘192.168.100.100’

config interface ‘wan’
option ifname ‘eth0.2’
option proto ‘dhcp’
option type ‘bridge’
option metric ’50’

config switch
option name ‘rt305x’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘rt305x’
option vlan ‘2’
option ports ‘4 6t’

config switch_vlan
option device ‘rt305x’
option vlan ‘1’
option ports ‘0 6t’

config interface ‘modem_usb’
option proto ‘dhcp’
option ifname ‘usb0’
option metric ‘100’

config interface ‘wwan’
option dns ‘8.8.8.8’
option proto ‘static’
option ipaddr ‘192.168.1.100’
option netmask ‘255.255.255.0’
option gateway ‘192.168.1.1’

config wifi-device ‘radio0’
option type ‘mac80211’
option hwmode ’11g’
option path ‘10180000.wmac’
option htmode ‘HT20’
option disabled ‘0’
option channel ‘auto’
option country ‘RU’

config wifi-iface
option device ‘radio0’
option mode ‘sta’
option network ‘wwan’
option ssid ‘НАЗВАНИЕ ВАШЕЙ WI-FI СЕТИ ‘
option key ‘ПАРОЛЬ ВАШЕЙ WI-FI СЕТИ ‘
option encryption ‘psk2+aes’

Командой wifi up включаем wifi на роутере. Немного подождем, если синий светодиод на роутере начнет мигать, то все OK.

Роутер можно перезагрузить и доступ к роутеру теперь будет по wifi по адресу 192.168.1.100. По lan можно зайти по адресу 192.168.100.100.

Читать еще:  Как войти в роутер без интернета

Hame MPR-A1 и клоны на чипе RT5350 (4 мб флэш)

Tplink tl-wr710v2.0 (4мб флэш)

Мануал от samur005 ( для прошивки «Хитрый Домовенок» )

Сообщение отредактировал ctich — 19.02.17, 22:12

Приветствую. К сожалению, я не сильный электронщик. Нарыл только в гугле это и это. И еще можно посмотреть на специализированных форумах.

Да не, тут вопрос не в программировании и не в даташите. Есть подозрение, что под openwrt уже и i2s драйвер есть. Например, в 15.05 есть пакет kmod-sound-mt7620, что вполне может оказаться одним из требуемых пакетов. а вот как оно шаг за шагом подключается и были ли успешные реализации подключения — не понятно. И сведения обрывочные только попадаются, что не могу полную картину воссоздать.
Для платформы ar9331 (tp-link mr3020) китайцы драйверы написали, когда создавали свой airmusic. А тут, вроде, и поддержка i2s изначально есть в процессоре, а полного мануала (по программной части) подключения dac по i2s шине нигде нет. Было бы здорово обойтись без ненужного преобразования через usb. И порт остался бы свободен.

Ладно, в общем, понял, не встречали. Будем искать.

Чем плохо такое преобразование ? Вносятся шумы, искажения при воспроизведении аудио ?

Шумы вряд, это ж цифра. USB конвертер сужает возможности ЦАП по битности и частоте дискретизации. Кроме, того, очень существенно добавляет стоимости к конечному продукту (звуковой карте). Предложений ЦАП без конвертера USB масса — от Китая до «аудиофильских» платок к малинке. После покупки именитой Creative SB Play, как раз для целей подключения к роутеру, в звукашках «от брендов» я совсем разочаровался, ибо ЦАП там древний, как экскременты мамонта. Звук соответствующий.

Если из схемы выбросить USB звук и пересадить его на шину i2s, будет порт usb свободен (флешка для музыки) и можно не использовать USB хаб (он надежности не добавляет, из-за него возможны зависания). В общем, одни плюсы)

На wt3020 процессор mt7620n, на нем, похоже, линии i2s отключены. Доступны они на mt7620a, в xiaomi, но этот роутер пока новый, его никто особо не ковырял.

Спасибо, все работает,
На клоне HAME
Как бы еще добавить регулировку громкости и стоп произведения из веб морды? Звуковая к сожалению без кнопок.

Сообщение отредактировал D_MitriY — 17.03.16, 15:27

Если нужна громкость и кнопка выключения в вэб интерфейсе могу рекомендовать этот проект. Прошивка для RT5350 здесь.
Можно попробовать и скрестить.

Сообщение отредактировал sergej_a_g — 17.03.16, 19:59

Прошивка для прослушивания интернет радио на роутере. (WifiRadio.SU v114.Full)

Прошивка WifiRadio.SU Full с веб интерфейсом, для прослушивания интернет радио на роутерах с прошивкой Openwrt.

*На версиях Openwrt / Lede 17 и выше, возможно не будет работать поддержка формата AAC, либо совсем не работать (в таком случае установите версию Standard).

Возможности:

  1. Поддерживаемые потоки: MP3 (AAC, OGG — опционально при установке mpd-full*)
  2. Индикация проигрываемого трека: есть
  3. Функция Play/Stop: есть
  4. Веб интерфейс: настройки wifi, управление подписками, добавление своих станций, загрузка своих плейлистов, упрощенный пульт управления, управление громкостью, управление переключением станций, управление избранным, управление озвучкой, управление звуковым устройством, обновление прошивки.
  5. Время переключения между станциями:

После обновления прошивки, в веб интерфейсе обязательно нужно обновить страницу клавишами CTRL+F5.

V114.Full (18.04.2020) Важное!

  • Исправлено внезапное воспроизведение при остановленном прослушивании.

V113.Full (14.04.2020) Важное!

V112.Full (03.04.2020) Важное!

  • Исправлено произношение погоды и времени по расписанию.

V111.Full (25.03.2020) Важное!

  • Изменение в настройках погоды. Исправлена проблема городов, состоящих из двух слов.

V110.Full (20.03.2020) Важное!

  • Исправлена проблема обновления прошивки и плейлистов при недостатке свободной памяти

V106.Full (29.02.2020) Важное!

  • Исправлена и оптимизирована работа модуля переподключения

V102.Full (19.02.2020)

  • Исправлена ненужная пауза в озвучке, при старте устройства
  • Добавлена возможность произношения приветствия и погоды, через указанные промежутки времени
  • Добавлена функция вклвыкл уведомления о наличии обновления
  • Добавлена функция вклвыкл автообновления прошивки

V100.Full (28.01.2020)

  • Исправлены некоторые ошибки

V99.Full (23.12.2019)

  • Исправлены критические ошибки
  • Изменен погодный сервер (openweathermap.org)

V93.Full (01.12.2019)

  • Добавлена возможность добавлять город для погоды вручную. Для этого просто впишите название города в поле.

V92.Full (22.11.2019)

  • Исправлено произношение погоды.

V91.Full (13.11.2019)

  • Оптимизация размера прошивки.

V89.Full (09.11.2019)

  • Добавлена кнопка Play/Stop в веб интерфейс.
  • Доработано состояние прогресса громкости.

V88.Full (23.10.2019)

  • Оптимизирован модуль инициализации.

V87.Full (22.10.2019)

  • Добавлена возможность листать избранные станции вперед и назад (/www/cgi-bin/wr_nextfav и /www/cgi-bin/wr_prevfav). Функции можно привязать на пульт управления.

V86.Full (09.10.2019) Важное!

  • Важные изменения в работе сервера, на прошивках ранних версий полная работоспособность не гарантируется.

V85.Full (30.09.2019)

  • Добавлена возможность обновления списка профилей с сервера для дистанционного управления с USB устройств ( При обновлении, файл конфигурации изменяется! ).
  • Добавлен профиль управления переключением станций USB мышью.
  • Исправлена неверная работа кнопки Mute/Unmute на странице виртуального пульта управления.

V84.Full (06.08.2019)

  • Добавлена возможность выбора голоса озвучки (муж/жен).
  • Исправлена проблема с отображением тэгов на некоторых станциях.
  • Обязательно нужно выбрать голос озвучки в веб интерфейсе, и сохранить параметры после прошивки!

V81.Full (12.05.2019)

  • Добавлено оповещение при начале и завершении обновления прошивки.

Порядок установки прошивки на роутер.

Для установки нам понадобится:

  1. роутер прошитый на openwrt с веб интерфейсом LuCI
  2. имеющий usb порт
  3. имеющий

4 мегабайта свободной flash памяти для установки всех компонентов (можно расширить память при помощи внешней флешки)

  • также необходим usb звуковой адаптер или usb наушники
  • Для начала опишу настройку wifi в режиме клиента. После настройки радио будет видеться в Вашей основной сети и иметь доступ к интернет по wifi.

    /etc/config/wireless (добавляем в Ваш файл)

    /etc/config/network (полностью заменяем Ваш файл, но параметр option ifname ‘eth0’ меняем на свой)

    /etc/config/firewall (полностью заменяем Ваш файл)

    После редактирования этих файлов нужно перезагрузить роутер.

    Далее устанавливаем саму прошивку.

    Автоматический вариант установки через telnet или ssh (putty, xshell):

    Если позволяет память, вместо mpd-mini нужно установить mpd-full , тогда появится поддержка AAC потоков. Инструкция по расширению памяти при помощи usb флешки по этой ссылке »

    После выполнения этих команд роутер перезагрузится и заиграет радио.

    Чтобы попасть в web интерфейс с настройками, необходимо в браузере открыть:

    Через web интерфейс можно управлять следующими функциями:

    • Переключать станции
    • Управлять громкостью
    • Управлять избранным (для переключения usb клавиатурой или андроид приложением)
    • Загружать плейлисты
    • Добавлять и удалять станции
    • Управлять подпиской на плейлист
    • Управлять озвучкой станций
    • Настраивать звуковое устройство
    • Настраивать WiFi подключение
    • Обновлять прошивку через OTA

    Управление аппаратной кнопкой WPS на роутере: (нажатие 0-1 сек.) следующая станция, (нажатие 2-4 сек.) предыдущая станция, нажатие на кнопку (5-9 сек.) возвращает на первую станцию в списке.

    *При использовании usb клавиатуры возможны несовпадения кодов событий, поэтому нужно будет подправить файл example.conf в папке triggerhappy/triggers.d

    *Также возможно придется изменить название звукового устройства для управления громкостью. Сделать это можно через веб интерфейс.

    Если возникнут вопросы, с радостью отвечу на них.

    Ссылка на основную публикацию
    ВсеИнструменты
    Adblock
    detector