Wi fi интернет радио - Связь и коммуникации
Naautsorse.ru

Связь и коммуникации
2 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Wi fi интернет радио

Wi fi интернет радио

Сообщение отредактировал emirov84 — 21.12.16, 14:21

Какие модели мобильных роутеров можно использовать для создания wifi интернет радио ?

1) Nexx WT3020H(F) ( флэш память 8 мб, ОЗУ- 64 мб )
2) Xiaomi Mi-router mini
3) Клоны Hame MPR-A1 на чипе RT5350 ( у меня клон с флэш 4 мб, ОЗУ-32 мб )
4) GL-MT300N ( флэш память 16 мб, ОЗУ- 64 мб )

Выбор операционной системы.

Выбор дополнительного оборудования.

1) Внешняя аудиокарта с кнопками для управления.
2) USB наушники с кнопками для управления
3) Портативная аудиоклонка

С помощью шнурка подсоеденить роутер (вход Lan на роутере) к сетевой карте компьютера.

Прежде чем заливать прошивку, поменяем загрузчик на U-boot. Файл загрузчика скачаем отсюда. Затем будем делать по шагам :

1.Записываем на флэшку u-boot-nexx-3020-7620.bin
2. Подключаем ее в роутер
3. Заходим на роутер по телнет на адрес 192.168.8.1 с логином nexxadmin и паролем y1n2inc.com0755
4. Вводим в командной строке

5. На всякий случай сделаем бэкап

for i in 0 1 2 3; do cat /dev/mtdblock$i > mtdblock$i.bin; done

mtd_write -r -e mtd0 write u-boot-nexx-3020-7620.bin mtd0

После этого роутер должен перезагрузиться с новым загрузчиком, но со старой прошивкой. После выполнения этого шага питание от роутера можно отключить.

Чтобы попасть в загрузчик теперь необходимо зажать кнопку сброса и включить роутер. Подержать 3 секунды и загрузчик запустится в режиме http-сервера на 192.168.1.1. Затем в вэб интерфейсе загрузчика идем по пути Firmware Upgrade, ставим птичку на пункте Firmware, нажимаем Browse и ищем на диске нашу прошивку openwrt-15.05-ramips-mt7620-wt3020-8M-squashfs-sysupgrade.bin и потом Upload. Загрузчик считает прошивку и зеленым цветом известит нас что все в порядке и можно прошиваться. Этот процесс займет пару минут и роутер опять перегрузится. Далее можно заходить браузером по адресу 192.168.1.1 в вэб интерфейс OpenWrt для дальнейшей настройки. Логин по умолчанию root. Пароль придумаете сами. Этот пароль будет использоваться для доступа к роутеру по SSH.

В вэб интерфейсе OpenWrt настроить wifi как клиент. Т.к роутер в дальнейшем будет скачивать с инета пакеты для работы.

1. Зайдем через SSH под рутом по адресу 192.168.1.1 и поставить недостающие пакеты

opkg update
opkg install kmod-sound-core kmod-usb-audio kmod-input-core kmod-input-evdev madplay alsa-utils triggerhappy kmod-hid kmod-usb-hid

3. Выложить содержимое приложенного архива radio.zip в корень файловой системы роутера
4. Поставить права доступа на скрипты

chmod 755 /etc/init.d/webradio
chmod 755 /www/cgi-bin/webradio/items.cgi
chmod 755 /www/cgi-bin/webradio/update.cgi
chmod 755 /www/scripts/getstreammeta.sh
chmod 755 /www/scripts/playback.sh
chmod 755 /www/scripts/playstream.sh
chmod 755 /www/scripts/stopstream.sh
chmod 755 /www/scripts/streamcontrol.sh
chmod 755 /www/scripts/webradio.sh

5. Включить triggerhappy и радио в автозагрузку

/etc/init.d/triggerhappy enable
/etc/init.d/webradio enable

6. Перезагрузить роутер и если все сделано правильно, то по адресу

появится простой веб-интерфейс для управления радио и начнется воспроизведение первой станции из списка.

С помощью элементов управления можно менять позицию той или иной станции, удалять станцию, добавлять станцию. При этом ее название автоматически будет добавляться в каталог.
Нажимая кнопки Vol+ и Vol- можно менять громкость станции, а кнопкой Mute переключать станции вперед по кольцу. Название станции будет проговаривать синтезатор голоса.

Загрузчик менял по методу изложенному в этом посте.

Т.к. у меня клон Hame mpr-a1 с флэш 4 мб, то прошить в лоб стандартный пакет Openwrt и потом вручную установить пакеты как в посте выше просто не получится. В флэш памяти моего роутера не хватает места. Поэтому пришлось собрать прошивку с уже внедренными пакетами.

Прошивку можно скачать по этой ссылке.

Прошивка заливается в роутер с помощью китайской утилиты.

Затем по телнет на адрес 192.168.1.1 и ввести команду passwd. Вводим новый пароль. Теперь можно заходить на роутер с помощью WinSCP. На роутере надо поднять wifi. Для этого в каталоге /etc/config меняем содержимое файла network :

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd85:d10f:62c9::/48’

config interface ‘lan’
option ifname ‘eth0.1’
option type ‘bridge’
option proto ‘static’
option gateway ‘192.168.1.1’
option dns ‘77.88.8.7’
option netmask ‘255.255.255.0’
option ip6assign ’60’
option ipaddr ‘192.168.100.100’

config interface ‘wan’
option ifname ‘eth0.2’
option proto ‘dhcp’
option type ‘bridge’
option metric ’50’

config switch
option name ‘rt305x’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘rt305x’
option vlan ‘2’
option ports ‘4 6t’

config switch_vlan
option device ‘rt305x’
option vlan ‘1’
option ports ‘0 6t’

config interface ‘modem_usb’
option proto ‘dhcp’
option ifname ‘usb0’
option metric ‘100’

config interface ‘wwan’
option dns ‘8.8.8.8’
option proto ‘static’
option ipaddr ‘192.168.1.100’
option netmask ‘255.255.255.0’
option gateway ‘192.168.1.1’

config wifi-device ‘radio0’
option type ‘mac80211’
option hwmode ’11g’
option path ‘10180000.wmac’
option htmode ‘HT20’
option disabled ‘0’
option channel ‘auto’
option country ‘RU’

config wifi-iface
option device ‘radio0’
option mode ‘sta’
option network ‘wwan’
option ssid ‘НАЗВАНИЕ ВАШЕЙ WI-FI СЕТИ ‘
option key ‘ПАРОЛЬ ВАШЕЙ WI-FI СЕТИ ‘
option encryption ‘psk2+aes’

Командой wifi up включаем wifi на роутере. Немного подождем, если синий светодиод на роутере начнет мигать, то все OK.

Роутер можно перезагрузить и доступ к роутеру теперь будет по wifi по адресу 192.168.1.100. По lan можно зайти по адресу 192.168.100.100.

Hame MPR-A1 и клоны на чипе RT5350 (4 мб флэш)

Tplink tl-wr710v2.0 (4мб флэш)

Мануал от samur005 ( для прошивки «Хитрый Домовенок» )

Сообщение отредактировал ctich — 19.02.17, 22:12

Приветствую. К сожалению, я не сильный электронщик. Нарыл только в гугле это и это. И еще можно посмотреть на специализированных форумах.

Читать еще:  Beeline раздача интернета с телефона

Да не, тут вопрос не в программировании и не в даташите. Есть подозрение, что под openwrt уже и i2s драйвер есть. Например, в 15.05 есть пакет kmod-sound-mt7620, что вполне может оказаться одним из требуемых пакетов. а вот как оно шаг за шагом подключается и были ли успешные реализации подключения — не понятно. И сведения обрывочные только попадаются, что не могу полную картину воссоздать.
Для платформы ar9331 (tp-link mr3020) китайцы драйверы написали, когда создавали свой airmusic. А тут, вроде, и поддержка i2s изначально есть в процессоре, а полного мануала (по программной части) подключения dac по i2s шине нигде нет. Было бы здорово обойтись без ненужного преобразования через usb. И порт остался бы свободен.

Ладно, в общем, понял, не встречали. Будем искать.

Чем плохо такое преобразование ? Вносятся шумы, искажения при воспроизведении аудио ?

Шумы вряд, это ж цифра. USB конвертер сужает возможности ЦАП по битности и частоте дискретизации. Кроме, того, очень существенно добавляет стоимости к конечному продукту (звуковой карте). Предложений ЦАП без конвертера USB масса — от Китая до «аудиофильских» платок к малинке. После покупки именитой Creative SB Play, как раз для целей подключения к роутеру, в звукашках «от брендов» я совсем разочаровался, ибо ЦАП там древний, как экскременты мамонта. Звук соответствующий.

Если из схемы выбросить USB звук и пересадить его на шину i2s, будет порт usb свободен (флешка для музыки) и можно не использовать USB хаб (он надежности не добавляет, из-за него возможны зависания). В общем, одни плюсы)

На wt3020 процессор mt7620n, на нем, похоже, линии i2s отключены. Доступны они на mt7620a, в xiaomi, но этот роутер пока новый, его никто особо не ковырял.

Спасибо, все работает,
На клоне HAME
Как бы еще добавить регулировку громкости и стоп произведения из веб морды? Звуковая к сожалению без кнопок.

Сообщение отредактировал D_MitriY — 17.03.16, 15:27

Если нужна громкость и кнопка выключения в вэб интерфейсе могу рекомендовать этот проект. Прошивка для RT5350 здесь.
Можно попробовать и скрестить.

Сообщение отредактировал sergej_a_g — 17.03.16, 19:59

Wi-Fi радиоприемник с интернетом: какой лучше выбрать?

Как-то ко мне обратился мой постоянный читатель и сказал, чтобы я сделал обзор на интернет радиоприемники с Wi-Fi. Честно сказать не сразу понял его. И мне в голову приходило много разных вещей. В итоге пришлось немного попотеть, чтобы нарыть хоть какой-то информации. Для меня было удивлением существования такого «Франкенштейна». Сегодня в статье расскажу всё про Wi-Fi радиоприемник.

Давайте коротенько – для чего эта штука нужна. Есть много меломанов, которых не устраивает поп-музыка, напичканная нашими радиостанциями. А что-то более приличное, можно найти на радио в интернете. Будь это классика, рок, метал, джаз или рэп. Что-то совсем специфическое редко встретишь в чартах на популярных радиостанциях.

И тут приходит вопрос, а как тогда слушать музыку на любимым радиостанциях именно из интернета. Подключать телефон и слушать постоянно в наушниках – не всегда удобно. Знаю с десяток людей, который любят слушать звук в живую. Ставить обычную радиостанцию – бессмысленно.

Так как она ловит только ближайшие радиоканалы. И тут на помощь приходит, не очень популярный радиоприёмник с вай-фай модулем. Он подключается к интернету через вайфай. А там можешь слушать любую радиостанцию, которая находится в базе. Теперь предоставлю несколько хороших моделей, который нашёл во всемирной паутине.

Net’n’Joy NJ-004

Prology WR-100

Поддерживает подключение более 10 000 радиостанций по всему земному шару. Можете слушать почти всё что угодно. Единственный минус – высокая цена.

SANGEAN WFR-1DI

Качественные материалы, два мощных динамика. Отличные высокие и глубокие низкие частоты. Есть собственный сервис Wifiradio-frontier с более чем 15000 радиостанциями. Есть удобный дисплей и антенна для подключения обычного аналогового радио. Корпус сделан из дерева и имеет стильный дизайн. Из всех представленных мною моделей – самая дорогая, цена варьируется от 22 до 25 тысяч деревянных.

Xoro HMT-390

Помимо радио, вы можете на широкоформатном дисплее смотреть видео и даже просматривать страницы на сайтах. Разрешение экрана – 1024х600 пикселей. Устройство можно спокойно подключать как внешние колонки от телефона, компьютера, ноутбука или планшета.

Поддержка DLNA – можно слушать музыку, смотреть картинки, видео с компьютера, ноутбука, который также находится в одной локальной сети. Можно подключать флэшки, так как на задней панели присутствует USB разъём. Для подключения можно использовать как WiFi, так и проводное подключение к роутеру. В интернет-магазинах цена начинается от 11 000 рублей.

Как правильно выбрать?

Теперь мы подобрались к вопросу выбора. Как вы, наверное, заметили, эти игрушки стоят достаточно дорого, а цена самого дешёвого начинается с 8000 рублей. На самом деле высокая цена обусловлена тем, что эти аппараты очень редкие в использовании. Так же есть много моделей на китайском сервисе «Aliexpress». Очень хорошо отношусь к этому сервису и аппаратуру китайцы стали делать куда лучше, чем те же 10 лет назад.

Не рекомендую вам брать радиоприёмники оттуда. Дело в том, что во всех таких приёмниках сразу вшит сервис огромной базы данных радиостанций. То есть ты подключаешься и просто выбираешь станцию по своему вкусу. У китайских аппаратов, все сделано для китайцев и радиостанции он ловит исключительно азиатские.

Конечно, вы можете купить приёмник оттуда и скачать прошивку с интернета, но на самом деле это ещё тот геморрой для обычного меломана. Поэтому лучше брать варианты с запада. Далее, на что следует обращать внимание – на качество звука. Оно определяется в поддержке широкого диапазона частот. Чем шире диапазон, тем больше звуков вы услышите.

Читать еще:  Антенна для мобильного интернета своими руками

Но тут нужно также учитывать и сами радиостанции – то есть на какой скорости они передают информацию. Даже если у вас будут крутые колонки и приёмник – но станция транслирует сигнал с низкой скоростью, то и звук будет плохим. Правда с этим не должно возникнуть проблем, так как сейчас даже не популярные станции передают хороший звук.

Лучше выбирать коробку из дерева и с двумя колонками. Чем больше диаметр колонок, тем глубже будут низы — это для любителей басов. Не нужно брать сильно дешёвые модели, которые могут быстро выйти из строя или будут иметь плохой звук. На счёт дисплея – считаю это уже извращение и достаточно использовать экран телефона. Но может кому будет нужно – поэтому последнюю модель выбрал, именно с экраном.

Ещё один совет – если есть возможность выбрать динамики вживую, то обязательно послушайте. Потому что можно бесконечно говорить о качестве звука, но лучше дать возможность выбрать радиоприемник вашим ушам – они точно не ошибутся.

Все необходимое для самостоятельной сборки Web-радиоприемника

Вы могли слышать про популярные радиоприемники, которые получают сигнал трансляций из интернета. Для работы подобного устройства не нужна радиотрансляционная вышка — только домашний Wi-Fi. Умельцы стилизуют свои самодельные Web-радиоприемники под олд-скульную и винтажную технику. А готовые устройства стоят весьма не скромно. В этой статье расскажу, как самостоятельно собрать интернет-радио с минимальными затратами.

Для сборки вам потребуется:
1. Источник питания (от 5 до 24 В). Пойдут старые блоки питания от гаджетов, ноутбуков и так далее. Возможно потребуется отдельный преобразователь для контроллера (для понижения с 24 до 5 В).

2. Корпус. Можно использовать старые корпуса от гаджетов, старой аудио-видео техники. Хороший вариант — встроить контроллер в активные компьютерные колонки — приличный вид плюс усилитель, динамики и источник питания. Можно сделать корпус с нуля — из пластика, ДСП, картона и т.п. Основная проблема будет — сделать аккуратную переднюю панель.

3. Контроллер для интернет радио. Это модуль с Wi-Fi и открытой прошивкой. Можно использовать роутер с Open-WRT, можно отдельный контроллер на ESP32/8266. Желательно брать сразу с дисплеем, так как будет компактнее и проще готовое изделие.

4. Аудиомодуль и аудиоусилитель. Если контроллер не имеет встроенной микросхемы для вывода звука, то лучше приобрести отдельный ЦАП с интерфейсом I2S. Потребуется также и усилитель звука для вывода на мощные колонки.

5. Динамики или колонки. Самый простой вариант — колонки от портативной акустики, это компактные и широкополосные варианты на 2″ или 3″.

6. Прямые руки для того, чтобы собрать все вместе, спаять, залить прошивку, IP адреса вещания, а также придать приличный внешний вид готовому устройству.

Контроллеров несколько, на выбор. Самый простой вариант (Kit8) стоит около $4.9, вариант с дисплеем побольше (T-Display) около $10, но обратите также внимание на функциональные варианты, например, T-Audio со встроенным ЦАП-ом.

Это, наверное, самый простой вариант (Wi-Fi Web Kit8) — модуль на базе NodeMCU/ESP-8266 со встроенным дисплеем и USB интерфейсом. Подходит не только для проектов интернет-радио, но и для самодельных RC-моделей, для умного дома, IoT и так далее. Модуль предусматривает несколько дискретных входов-выходов, а также аналоговый (А0).

Неплохой вариант — контроллеры от TTGO. Этот вариант чут-чуть подороже, но и экран побольше. Модуль может быть интереснее, как управляющий модуль для интернет радио. На экране можно выбирать нужную «радио-волну», а кнопками подтверждать выбор. Аналогично предыдущей плате, модуль имеет интерфейс USB.

Достаточно дорогой, но популярный модуль TTGO T5s. Версия платы V2.1, остнован на ESP32 и огромном 2,7″ дисплее Е-ink (E-Paper). Модуль имеет встроенный микрофон, ЦАП МAX98357A, ридер SD карты, bluetooth. Это одно из готовых решений для интернет-радио.

Самый фукциональный модуль от TTGO, заточенный под воспроизведение аудио. Это T-Audio (альтернативное название WROVER ESP32). Имеет интересную круглую форму платы под портативные колонки — как раз вариант под самодельный корпус из водопроводной трубы. На плате расположен ридер SD карт, bluetooth, WI-FI, ЦАП WM8978, светодиод WS2812B RGB и акселерометр MPU9250.

Последние два модуля имеют встроенный ЦАП, а для остальных следует приобрести отдельный шилд с микросхемой для вывода звука (I2S DAC). Эти шилды заточен под вывод звука с контролера через интерфейс I2S (стандартный). Из цифрового потока в аудио преобразование выполняет специальный ЦАП PCM5102.

В первом лоте есть в комплекте передняя панель, останется найти только коробку. По качеству неплохие и громкие (широкополосные). Вторые динамики совсем дешевые ($2), но пойдут для пробы.

Недорогой усилитель PAM8610 с двумя выходами по 2х10 Вт — пригодится для усиления звука на динамики. Это самые популярный и недорогой усилитель сигнала класса D. Подключение проблем не вызывает — правый/левый каналы, питание, динамики.

Недорогой усилитель PAM8610 с двумя выходами по 2х10 Вт с регулировкой звука. Такой же, как и предыдущий, недорогой, но с распаянным фильтром и коннекторами для удобства. Я рекомендую именно такой, особенно если есть возможность расположить все в корпусе.

Корпус можно собрать из подручных материалов — взять старую коробку из-под устройств, компьютерные колонки, старые DVD плееры или радиоприемники.

Все указанные модули прошиваются из Arduino. Прошивки открытые.

Если честно, то это одни из лучших проектов для самостоятельно сборки. Очень полезное применение недорогих комплектующих, паяльника и своего времени. Если вы пытаетесь увлечь сына программированию, то это простой и наглядный способ рассказать что и как. Если вы подбираете проект для школы или института, то тоже рекомендую обратить внимание, так как подобные проекты в последнее время наиболее актуальны.

Читать еще:  Tele2 интернет для компьютера

Обзор Xiaomi WiFi Online Radio — беспроводной колонки и интернет-радио в одном устройстве

Компактный Wi-Fi-приёмник от Xiaomi, который позволяет без компьютера и смартфона прослушивать множество онлайн-радиостанций.

Сразу оговоримся, что хотя в тексте будет часто встречаться слово «радио», речь не идёт о классических радиоволнах. Xiaomi WiFi Online Radio представляет из себя устройство нового типа, которое способно не только выполнять роль обычной беспроводной колонки, но и может подключаться к интернету и воспроизводить музыкальные, новостные, спортивные станции.

Xiaomi WiFi Online Radio поставляется в небольшой картонной коробочке белого цвета. Внутри находится сам приёмник и USB-кабель для подзарядки. Он, кстати, тоже белого цвета, плоский и довольно длинный.

Колонка имеет форму куба с размерами сторон 8,3 × 8,3 × 5 сантиметров. Корпус выполнен из белого глянцевого пластика, высокое качество которого не вызывает сомнений. Все грани, примыкающие к задней крышке, плавно закруглены, благодаря чему устройство приятно брать в руки.

На передней поверхности находится сетка динамика. Сверху — сенсорная полоска для изменения громкости, обозначенная рядом серых точек. Сбоку от неё выделяется ярко-красный рычажок для переключения станций.

На задней поверхности расположены гнездо для подключения USB-кабеля и индикатор режимов работы. Обратите внимание на маленькое отверстие рядом — оно служит для полного сброса настроек устройства.

Для активации гаджета необходимо долго нажимать на красный рычажок. Однако ничего интересного при первом включении не происходит: просто загорается индикатор сзади, приятный голос говорит несколько слов на китайском языке и всё. Для полноценного использования устройство необходимо настроить. И вот тут начинается самое интересное.

Xiaomi WiFi Online Radio предназначено исключительно для китайского рынка, поэтому заточено под местного потребителя. Это значит, что проигрывать оно умеет в основном китайские интернет-радиостанции, что, разумеется, не радует. Однако отечественные умельцы нашли выход из положения.

Прежде всего необходимо установить на смартфон приложение Mi Home, которое имеет версии для Android и iOS.

Обратите внимание, что при первом запуске приложение попросит вас создать новый или войти в существующий Mi-аккаунт. В настройках в графе «Местоположение» необходимо указать «Материковый Китай», иначе радио подключить не получится. Затем следует нажать на плюсик в правом верхнем углу главного окна Mi Home и подождать, пока смартфон обнаружит новое устройство. Xiaomi WiFi Online Radio в это время тоже должно быть включено.

После сопряжения устройств следует указать сеть Wi-Fi, к которой необходимо подключиться, и ввести пароль, если это необходимо. Затем приёмник самостоятельно обновит прошивку и загрузит список доступных радиостанций. Он очень большой, но в основном включает музыку и информацию на китайском языке.

Впрочем, даже здесь можно найти пару десятков подходящих потоков. Просто введите название своего любимого музыкального жанра, а затем добавьте появившиеся в результатах поиска станции в избранное. Они сразу же окажутся в памяти устройства и можно будет начинать прослушивание.

Однако мы не будем на этом останавливаться, а пойдём дальше. Наша задача — научить радио петь и разговаривать на русском, украинском, белорусском и других привычных языках. Для этого необходимо посетить страницу проекта Ximiraga. Его создатели смогли создать специальный сервер, который транслирует онлайн-потоки самых популярных радиостанций в понятном для Xiaomi WiFi Online Radio формате.

Все инструкции по настройке доступа к серверу Ximiraga есть на сайте в разделе «Установка». Сделать это совсем не трудно: нужно просто изменить адрес DNS-сервера на вашем смартфоне или роутере. Если прочитанное только что предложение не вызвало у вас никакого удивления, то вы легко с этим справитесь. Если же вы ничего не поняли, то найдите компьютерного специалиста, который за две минуты всё настроит.

После подключения к серверам Ximiraga в списке доступных потоков появятся десятки отечественных радиостанций. С их полным перечнем можно ознакомиться здесь. Кстати, если всё-таки не найдёте своей любимой, то можно попросить администрацию её добавить.

Звуковая мощность Xiaomi WiFi Online Radio составляет всего 2 Вт, но этого вполне достаточно, чтобы наполнить звуком небольшое помещение. Качество воспроизведения сильно зависит от выбранной радиостанции, но для своего компактного формата звучит колонка неплохо.

Встроенного аккумулятора на 1 000 мА·ч хватает для работы на протяжении 4−5 часов при среднем уровне усиления. Если хорошо поковыряться в приложении Mi Home, то среди китайских надписей можно найти настройки автоматического включения по таймеру. Тогда колонка превращается в прикроватный будильник, который разбудит вас в назначенное время музыкой любимой радиостанции.

И последняя и самая простая возможность — использование Xiaomi WiFi Online Radio в качестве обычной беспроводной колонки. Для этого достаточно сдвинуть красный рычажок вверх или вниз и удерживать в таком положении в течение 2 секунд. Радио переключится в режим сопряжения по Bluetooth, после чего его можно подключить к смартфону или планшету.

Подводя итог, нужно отметить, что у компании Xiaomi получился довольно необычный и полезный гаджет.

Xiaomi WiFi Online Radio будет отлично себя чувствовать на прикроватном столике в качестве интернет-будильника, на кухне для фонового воспроизведения музыки или на рабочем столе студента. Словом, во всех случаях, когда главными приоритетами являются мобильность, удобство и стиль, данное устройство можно смело приобретать. Если же для вас важнее качество звука, то стоит обратить внимание на более серьёзную и габаритную акустику.

На момент написания статьи стоимость Xiaomi WiFi Online Radio составляет примерно 2 500 рублей.

Автор выражает благодарность магазину GearBest за предоставленное для тестирования устройство.

Ссылка на основную публикацию
ВсеИнструменты
Adblock
detector